Chapter 19

From RadiWiki
Jump to: navigation, search

Appendices

Appendix A: RadiMation® Support Procedure

Definitions

Malfunctions are divided in nine categories and prioritized on their severity:

  • 1 - Incorrect Measurement: RadiMation® software produces incorrect measurement results.
  • 2 - Issue with Data Loss: RadiMation® software contains a problem that resulted in a situation that data is lost.
  • 3 - Crash/Issue - No Data Loss: RadiMation® is aborted during operation without any specific reason or another issue occurred. After a restart, no data is lost.
  • 9 - Required device driver: A device driver for a measurement instrument must be created.
  • 4 - Mandatory New Functionality: Functionality that is currently not implemented, but that is required to provide support for a new standard or measurement method.
  • 5 - Unexpected Functionality: All other cases of malfunction of RadiMation®, where the software functionality is responding differently than expected.
  • 6 - Cosmetic: RadiMation® software functions normal but the lay-out of the tables, graphs or screens are not represented in a proper way. For example when:
    • (Parts of) labels or information are not displayed.
    • (Parts of) labels or information are overwritten by other labels or other information.
    • The screen 'flashes' while writing graphs or other information.
    • The manual contains an error or unclear description.
  • 7 - Questions: End-user has a question about the operation of the RadiMation® software.
  • 8 - Wish: RadiMation® software is missing specific functionality which should be evaluated for possible implementation in the future. In this category, there is not a real problem however the end-user requests RadiMation® to function in a different way or requests additional functionality. This can even mean that the actual situation is unworkable for the end-user. This case encompasses situations where certain functionality or part of tests is not supported.

Error report procedure

The goal of the 'Error report procedure' is to support customers as quick and effective as possible.

An issue could be a bug or something that is not working correctly, or working differently then expected. The goal of the error report procedure is to accomplish quick and effective support service. In general, a new problem (or issue) can only be solved if our RadiMation® support team will be able to reproduce the problem. The issue report procedure is intended to store and provide all relevant information that is needed to investigate and reproduce the issue.

RadiMation® incorporates the RadiLog automatic logging tool which is automatically running in background and captures all communication. In case of a problematic event, all relevant information can be transferred to the RadiMation® support team by pressing the Report button when there is an error. This form can also be accessed manually. It is of course also possible to send us any question directly by e-mailing us at radimation-support@raditeq.com.

Upon receipt of a new reported issue the RadiMation® support team will provide a unique issue number (#xxxxx). This reference number should be used during all further communication in relation to the specific issue.

Reporting a problem when an error is shown

When an error is shown within RadiMation®, the error can be directly reported to the RadiMation® support team.

  1. On the RadiMation® Error Window, press the Report button.
    ErrorPopupWindow.png
  2. The Error Report window will be shown.
    ReportErrorWindow.png
  3. Fill in all the additional information like requested. As seen in the screenshot, you must check the I agree that my provided data is used to improve the products and services of Raditeq checkbox.
  4. Check if you have filled all boxes. If not all boxes are filled you can not send or save the file. When information is missing a red circle with a cross is displayed. If you hover over it with your mouse it will tell you what is missing in the form.
  5. Once the report information is filled in the buttons change colour, the report can now be send to the RadiMation® support team in 2 ways:
    • Send the report automatically using the Send button.
    • Save the report with the Save button, and send the file over email to radimation-support@raditeq.com

The report automatically contains a log of all the recent communication with the test and measurement equipment. That information is very helpful and valuable to be able to resolve your issue.

Manually reporting an issue

If you would like to report a problem with RadiMation® without a RadiMation® error, you can also open the Error Report window from the Help menu:

   Menu.png Help
      Menu.png Report .

ManualReportMenu.png

Also if a test is already running, and you would like to report an error related to the running test, but no Error Report window is shown, then it is still possible to use this Help menu. The generated Error Report will then still contain the communication log of the running test.

Reporting a RadiLog communication file only

If for some reason the above reporting is not available, the communication log can also be reported manually. Please follow these instructions accordingly:

  1. Open the RadiMation® logging tool (RadiLog) from the View menu in RadiMation®
    ViewRadiLogMenu.png
  2. While the RadiLog tool is opened, reproduce the error.
  3. When the error has been logged, save the log file, by selecting 'File' and 'Save As...' from the menu.
    RadiLogSaveAs.png
  4. Send the .RadiLog file (zipped) to the RadiMation® support e-mail address radimation-support@raditeq.com

Sending larger files

It sometimes is required to send larger or additional files to the RadiMation® support team, however the general limitation for sending files by e-mail is limited to 6 MB files.

The Error Report functionality is able to include larger files (in total up to 100 MB). On the Files tab, a list of all the files that are contained in the Error Report is being shown.

ErrorReportFilesTab.png

Only the files that have a checked checkbox will be included in the transmission.

If one or more additional files should be transmitted to us, it is advised to create a ZIP file which contains all the files that should be included. Then that ZIP file can be drag-and-dropped from a Microsoft Windows Explorer window onto the list of files in the Error Report. The ZIP file will then be added and included in the Error Report that will be transmitted to us. In the example screenshot above, this has been done with the file 'Additional files.zip'.

The total size of all the files in the ErrorReport can be recalculated by clicking on the Report Size button.

Appendix B: Maintenance

The service of solving 'bugs' in the software is covered by the maintenance contract. Depending on the situation it might be necessary for an engineer from Raditeq to supply on-site support. These costs are covered as well, excluding travel and lodging. The service contract entitles the customer to all new push releases for the respective module(s).

Functionality improvements and/or changes to the respective software module(s) that are desired by the customer (and are assessed by Raditeq as functional and commonly applicable), will be implemented in a future release of the software. It is important to keep in mind that improvements and/or changes for one customer should not lead to disadvantages for other customers.

The RadiMation® Support/Upgrade contract is mandatory and should be ordered with each RadiMation® order.

  • The minimum duration of this contract is 2 years.
  • The first year is free of charge, each subsequent year costs 10% of the software order value.
  • the starting date of the support/upgrade contract is the original delivery and/or installation date.
  • If a customer does not accept a support/upgrade contact, Raditeq will not provide any software support/upgrade service.

Releases

Releases are divided in major and minor releases, indicated by a release number in the xxxx.yy.zz format. In this format, 'xxxx.yy' indicates the major release version. Where the 'xxxx' specifies in which year the software has been released. The '.yy' indicates if it is the first (.1) or second (.2) major release. The '.zz' specifies the minor release version.

RadiMation® software releases can be downloaded from our website at: http://download.radimation.com/ .

The changes that are included in each version is available in the release notes of each version, that is available on or [RadiWiki website ( http://wiki.radimation.com )].

Major release

A major release consists of any and all new functionalities and bug fixes since the previous minor release. As such the major release is a base line release.

Minor release

A minor release is provided on top of the major release, to provide fixes for problems that has been found in the major releases. No new functionality will be added in these minor releases.

Release Planning

There will be two major releases of RadiMation® each year. The planning of these two major releases is:

  • 1st major: first week of April.
  • 2nd major: first week of October.